压缩输出与 Go to Ruby 实现不同
你在学习Golang相关的知识吗?本文《压缩输出与 Go to Ruby 实现不同》,主要介绍的内容就涉及到,如果你想提升自己的开发能力,就不要错过这篇文章,大家要知道编程理论基础和实战操作都是不可或缺的哦!
我正在实现一个程序,将文件压缩为 git blob 并适当存储它。
我有一个基于 git 书中的文章的 ruby 参考实现
我正在尝试在此处实现此功能
但是,我遇到了一个问题,即每个实现中存储的压缩数据略有不同。
vbindiff 显示前 2 个字节是相同的(从这个测试脚本运行)(如果我没读错的话)。这些字节分别存储压缩方法和标志以及标志(根据 https://www.rfc-editor.org/rfc/rfc1950)。第三个字节是差异开始的地方,它要么是字典 ID,要么是原始输入数据的开始。数据保持相似,直到接近文件末尾。我假设这可能是 ADLER32 校验和的差异。
默认情况下,zlib 的 go 和 Ruby 实现似乎都不会向 zlib 传递字典(根据 go zlib 源和 ruby zlib 源)
数据看起来相同。
我不确定库中是否存在实现错误,或者我是否遗漏了某些内容。
为什么这些输出不同?
解决方案
RFC 1951 中定义的 deflate 算法(用于 RFC 1950 定义的 zlib 格式以及 RFC 1952 定义的 gzip 中)允许实现中的变化,这可能会在压缩时导致不同的结果。但这些结果仍然会解压缩到相同的值。这允许在压缩时间和压缩级别之间进行权衡,并使像 zopfli 这样的程序成为可能,它比原始 zlib 库实现更好的压缩(以明显更长的压缩时间为代价)。
Go 使用自己的用 Go 编写的 deflate 算法实现,而 ruby 使用 zlib library。这就是您的示例在同一输入上创建不同压缩输出的原因。但是,如果您从 Go 或 Ruby 程序中获取输出并再次解压缩(无论是使用 Ruby 还是 Go 或任何符合标准的实现),它都会得到完全相同的值。
今天关于《压缩输出与 Go to Ruby 实现不同》的内容就介绍到这里了,是不是学起来一目了然!想要了解更多关于的内容请关注golang学习网公众号!
华为折叠屏手机市场份额首超三星,DSCC发布最新预测
- 上一篇
- 华为折叠屏手机市场份额首超三星,DSCC发布最新预测
- 下一篇
- 如何理解bazel覆盖coverage.dat文件?
-
- Golang · Go问答 | 4分钟前 |
- Go http.Server.ConnContext 怎么为每条连接附加自定义元数据
- 313浏览 收藏
-
- Golang · Go问答 | 5分钟前 |
- Go http.Server.ErrorLog 怎样接管服务器内部错误输出
- 151浏览 收藏
-
- Golang · Go问答 | 10分钟前 |
- Go httptest.NewRequestWithContext 怎样测试请求上下文取消
- 230浏览 收藏
-
- Golang · Go问答 | 13分钟前 |
- Go testing/quick.Check 失败后怎样复现同一组输入
- 352浏览 收藏
-
- Golang · Go问答 | 15分钟前 |
- Go testing/quick.Value 为什么会拒绝含未导出字段的结构体
- 236浏览 收藏
-
- Golang · Go问答 | 17分钟前 | go · Go GOOS go/build Context.MatchFile 文件名约束
- Go go/build.MatchFile 为什么会受 GOOS 和文件名约束影响
- 261浏览 收藏
-
- Golang · Go问答 | 18分钟前 |
- Go ast.FilterFile 过滤声明时为什么会删除导入
- 417浏览 收藏
-
- Golang · Go问答 | 37分钟前 |
- Go go/doc.ToText 如何把注释格式化成终端文本
- 250浏览 收藏
-
- Golang · Go问答 | 40分钟前 | 标准库 · go · Go go/doc.Filter 文档树 未导出声明 公开API
- Go go/doc.Filter 怎样从文档树中移除未导出声明
- 178浏览 收藏
-
- Golang · Go问答 | 43分钟前 | go · Go runtime/coverage WriteCountersDir 覆盖率计数文件
- Go runtime/coverage.WriteCountersDir 生成的计数文件如何配合分析
- 341浏览 收藏
-
- Golang · Go问答 | 47分钟前 | 并发 · 读写锁 · go · Go sync.RWMutex tryLock 非阻塞写入
- Go sync.RWMutex.TryLock 怎样实现非阻塞写入尝试
- 360浏览 收藏
-
- Golang · Go问答 | 47分钟前 | go · Go runtime/coverage WriteMetaDir 覆盖率元数据
- Go runtime/coverage.WriteMetaDir 怎样保存原生覆盖率元数据
- 180浏览 收藏
-
- 前端进阶之JavaScript设计模式
- 设计模式是开发人员在软件开发过程中面临一般问题时的解决方案,代表了最佳的实践。本课程的主打内容包括JS常见设计模式以及具体应用场景,打造一站式知识长龙服务,适合有JS基础的同学学习。
- 543次学习
-
- GO语言核心编程课程
- 本课程采用真实案例,全面具体可落地,从理论到实践,一步一步将GO核心编程技术、编程思想、底层实现融会贯通,使学习者贴近时代脉搏,做IT互联网时代的弄潮儿。
- 516次学习
-
- 简单聊聊mysql8与网络通信
- 如有问题加微信:Le-studyg;在课程中,我们将首先介绍MySQL8的新特性,包括性能优化、安全增强、新数据类型等,帮助学生快速熟悉MySQL8的最新功能。接着,我们将深入解析MySQL的网络通信机制,包括协议、连接管理、数据传输等,让
- 500次学习
-
- JavaScript正则表达式基础与实战
- 在任何一门编程语言中,正则表达式,都是一项重要的知识,它提供了高效的字符串匹配与捕获机制,可以极大的简化程序设计。
- 487次学习
-
- 从零制作响应式网站—Grid布局
- 本系列教程将展示从零制作一个假想的网络科技公司官网,分为导航,轮播,关于我们,成功案例,服务流程,团队介绍,数据部分,公司动态,底部信息等内容区块。网站整体采用CSSGrid布局,支持响应式,有流畅过渡和展现动画。
- 485次学习
-
- PubMedQA
- 深入了解PubMedQA生物医学问答数据集,涵盖其核心功能、使用方法及在临床决策、药物研发等场景的应用,助力提升NLP模型性能。
- 448次使用
-
- H2O EvalGPT
- H2O EvalGPT是H2O.ai推出的开源LLM评估平台,提供详细的大模型性能排行榜、行业特定基准测试及A/B测试功能,助您快速选择最适合项目的高性能大语言模型。
- 519次使用
-
- LMArena
- LMArena是加州大学伯克利分校推出的AI模型匿名评测平台。通过盲测投票机制,用户可对比不同大模型回答并生成实时排行榜,助力开发者优化模型及用户选择最佳AI工具。
- 535次使用
-
- HELM
- 深入了解斯坦福推出的HELM(Holistic Evaluation of Language Models)大模型评测体系。本文解析其核心功能、安装配置步骤及应用场景,涵盖准确性、公平性、鲁棒性等多维度指标,助力开发者全面优化语言模型性能。
- 480次使用
-
- MMBench
- MMBench是由上海人工智能实验室等机构联合推出的多模态基准测试平台,提供细粒度能力评估、大规模数据集及VLMEvalKit工具。本文详细介绍其核心功能、安装使用方法及应用场景,助力开发者全面评估多模态模型性能。
- 304次使用
-
- 用Nginx反向代理部署go写的网站。
- 2023-01-17 502浏览
-
- GoLand调式动态执行代码
- 2023-01-13 502浏览
-
- Go crypto/rand.Text 的长度为什么不是固定字符数
- 2026-10-04 501浏览
-
- Go strings.ToValidUTF8 清洗日志内容的边界
- 2026-10-03 501浏览
-
- Go tls.GetCertificate 为什么收不到空 ServerName 请求
- 2026-09-27 501浏览

