当前位置:首页 > 文章列表 > Golang > Go问答 > Kubernetes 指南中有问题的“设置多个调度程序”

Kubernetes 指南中有问题的“设置多个调度程序”

来源:stackoverflow 2024-02-29 22:48:26 0浏览 收藏

哈喽!今天心血来潮给大家带来了《Kubernetes 指南中有问题的“设置多个调度程序”》,想必大家应该对Golang都不陌生吧,那么阅读本文就都不会很困难,以下内容主要涉及到,若是你正在学习Golang,千万别错过这篇文章~希望能帮助到你!

问题内容

当我尝试遵循 kubernetes 配置多个调度程序指南时,我无法成功运行 my-scheduler pod。

我成功构建了映像并将其推送到注册表,并且该映像显示在我的 docker 和 google could platform 中。 但是当我应用部署文件来设置 pod 时,状态为 crashloopbackoff。

my-scheduler-64576b7897-8b549            0/1     crashloopbackoff   14         84m

这是 kuberctl 描述 pod my-scheduler-64576b7897-8b549 -n kube-system 的输出:

name:               my-scheduler-64576b7897-8b549
namespace:          kube-system
priority:           0
priorityclassname:  
node:               minikube/10.0.2.15
start time:         tue, 07 may 2019 15:06:59 -0500
labels:             component=scheduler
                    pod-template-hash=64576b7897
                    tier=control-plane
                    version=second
annotations:        
status:             running
ip:                 172.17.0.15
controlled by:      replicaset/my-scheduler-64576b7897
containers:
  kube-second-scheduler:
    container id:  docker://a0cadf03dd5ffd11cbb6f1f8e669fc04cd6aa00aa6f361550f06f32785a4d63c
    image:         gcr.io/my-gcp-project-239900/my-kube-scheduler:1.0
    image id:      docker-pullable://gcr.io/my-gcp-project-239900/my-kube-scheduler@sha256:0895687b7646d159438f086e8f8b23b253332930e169cf29d8b9951ebf3ba653
    port:          
    host port:     
    command:
      /usr/local/bin/kube-scheduler
      --address=1.1.1.1
      --leader-elect=false
      --scheduler-name=my-scheduler
    state:          terminated
      reason:       error
      exit code:    1
      started:      tue, 07 may 2019 15:07:45 -0500
      finished:     tue, 07 may 2019 15:07:45 -0500
    last state:     terminated
      reason:       error
      exit code:    1
      started:      tue, 07 may 2019 15:07:24 -0500
      finished:     tue, 07 may 2019 15:07:24 -0500
    ready:          false
    restart count:  3
    requests:
      cpu:        100m
    liveness:     http-get http://:10251/healthz delay=15s timeout=1s period=10s #success=1 #failure=3
    readiness:    http-get http://:10251/healthz delay=0s timeout=1s period=10s #success=1 #failure=3
    environment:  
    mounts:
      /var/run/secrets/kubernetes.io/serviceaccount from my-scheduler-token-lzwvk (ro)
conditions:
  type              status
  initialized       true
  ready             false
  containersready   false
  podscheduled      true
volumes:
  my-scheduler-token-lzwvk:
    type:        secret (a volume populated by a secret)
    secretname:  my-scheduler-token-lzwvk
    optional:    false
qos class:       burstable
node-selectors:  
tolerations:     node.kubernetes.io/not-ready:noexecute for 300s
                 node.kubernetes.io/unreachable:noexecute for 300s
events:
  type     reason     age               from               message
  ----     ------     ----              ----               -------
  normal   scheduled  48s               default-scheduler  successfully assigned kube-system/my-scheduler-64576b7897-8b549 to minikube
  normal   pulled     2s (x4 over 47s)  kubelet, minikube  container image "gcr.io/my-gcp-project-239900/my-kube-scheduler:1.0" already present on machine
  normal   created    2s (x4 over 47s)  kubelet, minikube  created container kube-second-scheduler
  normal   started    2s (x4 over 47s)  kubelet, minikube  started container kube-second-scheduler
  warning  backoff    1s (x6 over 45s)  kubelet, minikube  back-off restarting failed container

当我尝试查看此 pod 的日志时,出现以下错误消息:

 standard_init_linux.go:207: exec user process caused "exec format error"

我的 dockerfile 与指南有点不同,它看起来像:

from busybox
add ./_output/local/bin/darwin/amd64/kube-scheduler /usr/local/bin/kube-scheduler

我变了

add ./_output/dockerized/bin/linux/amd64/kube-scheduler /usr/local/bin/kube-scheduler

进入

add ./_output/local/bin/darwin/amd64/kube-scheduler /usr/local/bin/kube-scheduler

因为 ./_output/local/bin/darwin/amd64/kube-scheduleri 是调度程序文件实际所在的位置。如果有人能告诉我为什么会发生这种情况,我也将不胜感激。

一些更新

不同的文件位置

按照指南,我在 shell 中输入了这些命令

git clone https://github.com/kubernetes/kubernetes.git
cd kubernetes
make

通过执行make,makefile文件会在特定路径下生成kubernetes exec文件(包括我们想要的kube-scheduler)。而且生成路径和你的系统有关。因为我使用 minikube 来运行 kubernetes 和 docker,并且它在 darwin(amd64) 上运行。我认为这就是我的道路与指南不同的原因。

“执行格式错误”

对于这个错误

 standard_init_linux.go:207: exec user process caused "exec format error"

我发现此问题建议在尝试在容器中运行命令之前添加 #!/bin/bash 。这告诉系统将命令视为 bash 命令。在 busybox 中,它应该是 /bin/sh。 (我对shell语言机制了解不多,如有错误请指正)

所以我在 my-sheduler.yaml 中更改了这些行:

- command:
 - /usr/local/bin/kube-scheduler
 - --address=0.0.0.0
 - --leader-elect=false
 - --scheduler-name=my-scheduler

进入

- command:
 - /bin/sh
 - /usr/local/bin/kube-scheduler
 - --address=0.0.0.0
 - --leader-elect=false
 - --scheduler-name=my-schedule

现在 my-sheduler pod 仍然失败并出现 crashloopbackoff 错误。 好消息是我现在在执行 kubectl logs 时有日志。 坏消息是日志像这样不可读

/usr/local/bin/kube-scheduler: line 1: ����: not found
/usr/local/bin/kube-scheduler: line 2: syntax error: unexpected ")"

我认为发生这种情况是因为 docker 镜像中发生了一些事情。但由于我直接使用 kubernetes github 页面上的脚本,所以不应该有任何错误。

当我运行 docker run -it {my-image-id} /bin/sh 并进入我的映像并运行 exec kube-scheduler 文件时,会显示相同的日志。

我无法弄清楚 go 脚本中的内容导致了此问题。

另一种选择

我最终尝试了另一种方法来构建我的自定义调度程序。

我遵循了本教程:https://www.youtube.com/watch?v=iycl0un1io0&t=1807s

您可以在这里找到源代码:https://github.com/kelseyhightower/scheduler

与官方指南相比,这个更加清晰(在官方指南中,您必须构建整个内容才能获取调度程序文件)。

希望如果有人遇到同样的问题,这会有所帮助。


解决方案


这看起来完全像是您正在使用 darwin kube-scheduler go 二进制文件在 Linux container 中运行。

您可能在 mac 上运行了这个:

git clone https://github.com/kubernetes/kubernetes.git
cd kubernetes
make

它创建了 darwin 二进制文件,而不是 linux 二进制文件。我会尝试从 linux 机器上运行它。或者更改 make 目标以使用 GOOS=linux and GOARCH=amd64。

请注意,截至撰写本文时,k8s 主要支持 linux,仅支持 windows 节点。

好了,本文到此结束,带大家了解了《Kubernetes 指南中有问题的“设置多个调度程序”》,希望本文对你有所帮助!关注golang学习网公众号,给大家分享更多Golang知识!

版本声明
本文转载于:stackoverflow 如有侵犯,请联系study_golang@163.com删除
gob:fasthbbftv1.BroadcastMessage接口类型未注册gob:fasthbbftv1.BroadcastMessage接口类型未注册
上一篇
gob:fasthbbftv1.BroadcastMessage接口类型未注册
Golang httptest 服务器循环引用
下一篇
Golang httptest 服务器循环引用
查看更多
最新文章
查看更多
课程推荐
  • 前端进阶之JavaScript设计模式
    前端进阶之JavaScript设计模式
    设计模式是开发人员在软件开发过程中面临一般问题时的解决方案,代表了最佳的实践。本课程的主打内容包括JS常见设计模式以及具体应用场景,打造一站式知识长龙服务,适合有JS基础的同学学习。
    543次学习
  • GO语言核心编程课程
    GO语言核心编程课程
    本课程采用真实案例,全面具体可落地,从理论到实践,一步一步将GO核心编程技术、编程思想、底层实现融会贯通,使学习者贴近时代脉搏,做IT互联网时代的弄潮儿。
    516次学习
  • 简单聊聊mysql8与网络通信
    简单聊聊mysql8与网络通信
    如有问题加微信:Le-studyg;在课程中,我们将首先介绍MySQL8的新特性,包括性能优化、安全增强、新数据类型等,帮助学生快速熟悉MySQL8的最新功能。接着,我们将深入解析MySQL的网络通信机制,包括协议、连接管理、数据传输等,让
    500次学习
  • JavaScript正则表达式基础与实战
    JavaScript正则表达式基础与实战
    在任何一门编程语言中,正则表达式,都是一项重要的知识,它提供了高效的字符串匹配与捕获机制,可以极大的简化程序设计。
    487次学习
  • 从零制作响应式网站—Grid布局
    从零制作响应式网站—Grid布局
    本系列教程将展示从零制作一个假想的网络科技公司官网,分为导航,轮播,关于我们,成功案例,服务流程,团队介绍,数据部分,公司动态,底部信息等内容区块。网站整体采用CSSGrid布局,支持响应式,有流畅过渡和展现动画。
    485次学习
查看更多
AI推荐
  • PubMedQA数据集详解:生物医学问答基准、功能与应用指南
    PubMedQA
    深入了解PubMedQA生物医学问答数据集,涵盖其核心功能、使用方法及在临床决策、药物研发等场景的应用,助力提升NLP模型性能。
    320次使用
  • H2O EvalGPT:开源LLM大模型评估与排行榜工具
    H2O EvalGPT
    H2O EvalGPT是H2O.ai推出的开源LLM评估平台,提供详细的大模型性能排行榜、行业特定基准测试及A/B测试功能,助您快速选择最适合项目的高性能大语言模型。
    376次使用
  • LMArena是什么?伯克利AI模型评估平台使用指南与功能解析
    LMArena
    LMArena是加州大学伯克利分校推出的AI模型匿名评测平台。通过盲测投票机制,用户可对比不同大模型回答并生成实时排行榜,助力开发者优化模型及用户选择最佳AI工具。
    373次使用
  • 斯坦福HELM:大语言模型Holistic Evaluation整体评估框架详解
    HELM
    深入了解斯坦福推出的HELM(Holistic Evaluation of Language Models)大模型评测体系。本文解析其核心功能、安装配置步骤及应用场景,涵盖准确性、公平性、鲁棒性等多维度指标,助力开发者全面优化语言模型性能。
    337次使用
  • MMBench详解:多模态大模型基准测试、功能特点与使用指南
    MMBench
    MMBench是由上海人工智能实验室等机构联合推出的多模态基准测试平台,提供细粒度能力评估、大规模数据集及VLMEvalKit工具。本文详细介绍其核心功能、安装使用方法及应用场景,助力开发者全面评估多模态模型性能。
    163次使用